
BP 210: Biological Light Microscopy 

Lab 8: Image ImageJ Tutorial and Cell Profiler 

  

Fiji Is Just ImageJ (we will call it ImageJ though out this document) with many of the plug-ins 
you will need to do image processing and to view your images.  

Cell profiler is a cell image analysis software that is ideal for analyzing a series of images in the 
exact same manner using pipelines. The CellProfiler project was started by Anne Carpenter and 
Thouis Jones, CellProfiler is now maintained by the Cimini Lab at the Broad Institute of MIT and 
Harvard.  

The CellProfiler team has made a large number of resources available for learning and using 
CellProfiler. For the lab we will be using the Translocation tutorial that has been put together by 
the Cell Profiler team as part of their outreach for teaching cell profiler 
(https://cellprofiler.org/outreach). 

 

Before Lab: 

Download Fiji here: http://fiji.sc/ 

Download and install Cell Profiler from https://cellprofiler.org  

Files for the Lab can be downloaded from this Box link BP210-Lab8 

 Slide1.ome.tif 
 

Information about ImageJ: 

The ImageJ site has links to documentation and resources available. There are many tutorials 
available online for ImageJ and  forum.image.sc hosts an active community where you can ask 
and find the answers to questions.  

The help menu also has links to plugin and Fiji documentation, the ImageJ tool bar also has a 
search feature! That says “click here to search” that can help you if you are lost. 

Goals For Fiji 

 Basics of Fiji looking at your images 
o Metadata 
o Brightness and contrast 
o Intensity 
o Non-destructive, destructive changes 

 Steps to segmenting  
o  Filters  
o thresholding 

Section 1- Basic Fiji 



Before next steps: Go to Plugins>Macros> Record, Leave window open off to the side 

We won’t be writing Macros today, but opening the recorder is a handy trick that lets you see 

what steps you have done and what certain buttons do. 

1. Before you open your image, make a copy of it incase you accidently save over it after 

permanently changing the data. Always have a backup of your raw data! 

a. Windows shortcut ( Ctrl + C then Ctrl + V ) 

b. Mac shortcut (Cmd+ D) 

2. Opening your image with the Bio formats importer 

a. Go to “Plugins > Bio Formats > Bio-Formats Plugins Shortcut window” 

b.  Another menu window will open, drag and drop Slide1.ome.tif on this window. 

c. This will open the Bio-Formats window. It has many options. Take a moment to 

explore the options by hovering over them. For our purposes, select the 

following:  

i. Stack viewing: Hyperstack 

ii. Metadata viewing: OME-XML metadata 

iii. Color Mode: Default 

iv. Everything else is unchecked 

d. Click “ok” 

e. The Window that opens will be black. Don’t Worry! 

 

3. Investigate the image data using the image window and OME Metadata window 

a. What does this tell you about the image? 

b. Camera: _________________________ 

c. Pixel Size: _______________________ 

d. Number of Pixels: __________________ 

e. Channels: ________________________ 

f. Bit depth: __________________________ 

 

4. Investigate the Image Window 

a. What can you tell from the Image window? Size, pixels, channels, colors, bit 

depth? 

        

5. Brightness & contrasts (B&C) 



Fiji Tool Bar: 

 

a. First move your mouse over the black image and look at the Fiji tool bar. Is the 

Value number changing?  What does that tell you?  

 

b. Let's bring the data into a range we can see. Go to “Image > Adjust > 

Brightness/Contrast”. (Windows: Ctrl + Shift + C, Mac: Cmd + Shift + C) 

c. Here you change the display of the data in relation to the histogram for each 

channel by moving the C bar then in the B&C window.  

i. Clicking “Auto”  

ii. Moving the sliders 

iii. Clicking “Set” and adding values directly 

iv. **Before you click “Apply”** Duplicate 

the Image, Go to Image>Duplicate 

d. Why is Apply different from the rest and why 

would you duplicate the image? (hint: mouse 

over the pixels) 

e. Which of the methods, Auto, Sliders, Set, 

Apply, are Destructive (change your data), 

which are non-destructive (leave data as-is) 

 

6. Measure non-destructive data changes of B&C 

a.  With the rectangle tool selected ,draw a rectangle on your image 

i. To Save this region to measure it later with the ROI manager. Press “t” or 

“Analyze > Tools > ROI Manager” then click “Add”. 

ii. Measure.  Press “m” or go to “Analyze > Measure”. What is the Mean 

intensity (shown as “Mean”)? 

1. If you do not see the "Mean”, in the Results window go to “Results 

> Set Measurements” and select “Mean grey value” 



b. Adjust the histogram, make it really bright or really dim with the sliders. Then 

measure again. What values do you see?  

 

 

 

7. Seeing in color 

a. Make a composite to see an overlay of all the images together (this will keep 

them as “separate” images). Go to “Image> Color> Make Composite” 

i. Slider with the C at the bottom of the window bottom now changes which 

channel the B&C window affects or is measured. 

ii. Change the color of the red channel (channel 2) to magenta to make it 

color blind friendly by moving the color bar to channel to then “Image > 

Look Up Tables” or “LUT” button and change the color.  

iii. Toggle channels on and off using the Channels Tool “Image > Colors > 

Channels Tool”  

 

8. Add scale bar 

a. Since we know the pixel size from the metadata, you can go to “Analyze> Tools> 

Scale Bar”.  

b. Keep in mind when your pixel size is being imported and when it is not. If your 

image did not have meta data, you would need to know the pixel size then go to 

“Analyze > Set scale” and input the data yourself 

 

9. Saving. “File > Save”  

Remember when presenting data you are comparing that everything should be scaled the 

same to represent data properly! 

TIP for future: if you go to “Set” in the B&C window there is a check box to “Propagate to all 

other X channel images” to set the scales the same 

Being color bling friendly it important! Check out the ASCBs quick guide for tips: 

https://www.ascb.org/science‐news/how‐to‐make‐scientific‐figures‐accessible‐to‐readers‐with‐

color‐blindness/  



a. Keep in mind how you want to use your data. Are you going to do further 

analysis? How do you want to save it? What format would you use to keep meta 

data? 

b. If you are going to write your image out for another purpose, such as a 

PowerPoint or a paper figure, you will need to downscale the data. When you do 

this, know how you are saving your data and what compression is being used, 

think about what compression you will use. Notes on file types below for future 

use. 

i. OME.TIFF – An Open microscopy environment TIFF format. Can save all 

your data as raw data (how you collected it) with Meta data 

ii. Compression: Lossless versus Lossy. Lossless = All data stays intact. 

Lossless = Reduces data file permanently (deletes information 

permanently, cannot be recovered) 

iii. JPG- uses Lossy compression! Will lead to artifacts if saved multiple 

times.  

iv. PNG – Lossless. High resolution format. 8Bit. 

v. GIF- animation sequence. Limited to 256 colors  

vi. MP4 – Movie file that is international standard. Has automatic encoding 

for lossy compression and for smoothing. 

vii. AVI – Multimedia container can store audio and video with various 

codecs. Generally compresses less, can even be uncompressed.  

c. TIP: If saving directly as PNG it will normalize the data without paying attention to 

how you scaled it. Convert to 8Bit color (Image>Type> 8-bit Color) first to 

preserve your scales, then PNG. 

 

Section 2 – Filters and Thresholds 

 

When setting up an image analysis pipeline a general pipeline will be as follows: 

  

Pre‐Processing

Filters

Enahancing Signal 

Segmentation

Thresholding

Creating binary objects

Post processing

Modifying binaries

Analysis

Measurements

or models



Visit https://www.allencell.org/segmenter.html to see more in detailed examples of pipelines. 

Because we are also going to be covering Cell Profiler, we are going to do a quick overview of 

some filters and thresholds to give and idea of what is going on “under the hood” of the modules 

then move to cell profiler. 

 

For all these examples we are going to use the actin (channel 2) from the Slide1.ome.tif image 

from step 1. We will be using this image to generally look at the process of steps you would take 

for segmentation and measuring specific objects.  

1. Duplicate the image before starting. You will need to duplicate the image multiple times 

during this section (anytime it changes, and you need a fresh image) so keep the raw 

image handy. 

a. Go to Image>Duplicate (or Windows: Cmd + Shift + D, Mac Cmd + Shift + D), 

Since we are working with channel 2/actin channel, you can duplicate just the 

actin channel by checking “duplicate hyperstack” and entering “2” in the box. 

b. Do a few times to test filters 

 

2. Check out some of the greyscale/rank filters then explore how they can be put to use. 

Don’t forget to duplicate your raw image. 

a. These are filters that change the information based on the grey-scale information 

of the pixels. Test out a few to see how they change the image (keep the 

windows open for further steps) 

i. Process > Filter > Gaussian Blur (try with preview on and change the 

Sigma) - Keep your Gausiian Blur window for Steps b and c. 

ii. Process> Filter> Find Edges 

iii. Process > FFT> Bandpass Filter (you can change or use default of large 

structure = 40 pixels, small structures = 3 pixels , suppress stripes = 

none, Tolerance of direction = 5%) 

 

 

Info: about the FFT Band Pass filter:  
It removes high spatial frequencies (blurring the image) and low spatial 
frequencies (similar to subtracting a blurred image). It can also suppress 
horizontal or vertical stripes that were created by scanning an image line by line.  
 
Learn more here: https://imagejdocu.list.lu/gui/process/fft  



 

 

3. Apply filters to reach goals: Many of the filters blur the data, which can be used for filling 

in gaps so we can segment a single object more easily. To see this, you can test your 

Gaussian-blurred image against your raw data 

a. For your Gaussian blurred image and a copy of your unfiltered blurred image test 

out data to threshold a single object (i.e. whole cells) easier: 

i. First convert both images to 8 bit (remember to these are duplicates). Go 

to Image> Type > 8bit  

ii. Run the auto threshold as in step 3  on both 8 bit images. Go to Image> 

Adjust> Auto threshold, make sure Method “Thry All” is selected and  

“White objects on black background” is clicked. Then press “OK” 

b. In general, how do the thresholds compare for filtered vs unfiltered? 

 

We are transferring to Cell Profiler. 

 Below is a section on binaries and creating selections if you want to know how to select a 

region you have segmented and then move back to your original data. 

c. NOTE: For the next step if continuing to binaries 

i.  Keep open the image from b.  

ii. Choose your favorite thresholding method and run the thresholding again 

on the image from b with just that method:  “Image> Adjust> Auto 

threshold”, In window that opens: Method “[your choice]” and Check 

“White objects on Black background” 

Section 5. Binaries and measuring 

For this section use what you learned above. Open the following files if you do not have 

them already: 

 Slide1.ome.tif raw image file data 

 Slide1 actin image (channel 2) processed for actin filaments 

 Thresholded image of the processed image, processed with the thresholding method of 

your choice (i.e. not the montage, when you run Auto threshold-just choose one not all) 



 

1. The Binaries menu allows you to adjust your thresholded image, where you could 

expand, shrink or use a number of other options (see here 

https://imagejdocu.list.lu/gui/process/binary).  

a. To get a feel for using binaries, the binaries options menu lets you see changes 

in real time. Click on your thresholded image so it is the active window then open 

the “Process > Binary> Options”. Click “Preview” to test out common methods in 

real time. 

i. Check “Black background” to affect the white binary. 

ii.  “Do:” is where the binary options are found. Test the erode and dilate 

options. What are they doing? 

iii. “Iterations” specifies the number of times the operation will be preformed 

test putting in a higher number with erode/dilate select to see what would 

happen if you ran it multiple times. 

iv. “Count” specifies the number of adjacent background pixels before one is 

removed (during erosion) or foreground pixels before one is added 

(dilate). 

2. You can perform measurements on your data based off thresholded region you have 

identified and modified. 

a. To select the binary region for measurement go to “Edit > Selection> Create 

Selection” then add to the region to the ROI manager (press “t”) 

b. For both your raw data and the processed data compare the mean intensity 

values for channel 2. Select channel 2 using the channel bar at the bottom. Then 

add your ROI from the binary by selecting it from the ROI manager. Preform the 

measurement by pressing “m”.  

i. If you don’t see the mean intensities, change the measurements you see 

by going to the Results window go to “Results > Set Measurements” and 

select “Mean grey value” 

c. Why would you measure the intensity values in the raw data window and not the 

processed window? 

d. If you only cared about total area, would it matter which window you measured it 

in? 

 

 



 

 

 

 

Section 6. Macros and Automation 

Macros can be a great way to automate a simple task such as going through a folder and 

converting each image or adding in some extra steps such as applying filters or measurements 

above.  

In the download materials, a Macro is included that, when run, will process a folder of images, 

run a threshold (here, the percentile is used), and then export the measurements to another 

specified folder. In the ImageJ macro language “//” will be ignored when running the script and 

everything in the script is commented to you can see what it is doing. More simple helpful 

macros can be found here:  https://ucsf-calm.github.io/wiki/pages/references-and-

education/Presentations.html  


